package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Aro.+|Cb.+|B[a-zA-Z\d]{5})[a-zA-Z\d]{6}`)
var str = `Brs0mjIzMzKz
B7U0kTIxMTG3
CbU0ljQzMDC2
CbU0ljIxMDe1
CbU0ljIxMDC2
CbU0ljQzMTK1
CbU0ljIxMDWx
CbU0ljAyMDKy
CbU0ljQyMzW6
CbU0ljIxMDO0
CbA0kTIxMzqz
Aro0lzI0NjKx
Aro0kjIxNzK2
Aro0lzIxNDu1
Aro0kjI0MjGw
BrA0kjAzMjC6
BrA0kzI0NDW6
BrA0kjIyMzW0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}