import Foundation
let pattern = #"(Aro.+|Cb.+|B[a-zA-Z\d]{5})[a-zA-Z\d]{6}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Brs0mjIzMzKz
B7U0kTIxMTG3
CbU0ljQzMDC2
CbU0ljIxMDe1
CbU0ljIxMDC2
CbU0ljQzMTK1
CbU0ljIxMDWx
CbU0ljAyMDKy
CbU0ljQyMzW6
CbU0ljIxMDO0
CbA0kTIxMzqz
Aro0lzI0NjKx
Aro0kjIxNzK2
Aro0lzIxNDu1
Aro0kjI0MjGw
BrA0kjAzMjC6
BrA0kzI0NDW6
BrA0kjIyMzW0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)