import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Aro.+|Cb.+|B[a-zA-Z\\d]{5})[a-zA-Z\\d]{6}";
final String string = "Brs0mjIzMzKz\n"
+ "B7U0kTIxMTG3\n"
+ "CbU0ljQzMDC2\n"
+ "CbU0ljIxMDe1\n"
+ "CbU0ljIxMDC2\n"
+ "CbU0ljQzMTK1\n"
+ "CbU0ljIxMDWx\n"
+ "CbU0ljAyMDKy\n"
+ "CbU0ljQyMzW6\n"
+ "CbU0ljIxMDO0\n\n"
+ "CbA0kTIxMzqz\n"
+ "Aro0lzI0NjKx\n"
+ "Aro0kjIxNzK2\n"
+ "Aro0lzIxNDu1\n"
+ "Aro0kjI0MjGw\n"
+ "BrA0kjAzMjC6\n"
+ "BrA0kzI0NDW6\n"
+ "BrA0kjIyMzW0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}