use strict;
my $str = 'Brs0mjIzMzKz
B7U0kTIxMTG3
CbU0ljQzMDC2
CbU0ljIxMDe1
CbU0ljIxMDC2
CbU0ljQzMTK1
CbU0ljIxMDWx
CbU0ljAyMDKy
CbU0ljQyMzW6
CbU0ljIxMDO0
CbA0kTIxMzqz
Aro0lzI0NjKx
Aro0kjIxNzK2
Aro0lzIxNDu1
Aro0kjI0MjGw
BrA0kjAzMjC6
BrA0kzI0NDW6
BrA0kjIyMzW0';
my $regex = qr/(Aro.+|Cb.+|B[a-zA-Z\d]{5})[a-zA-Z\d]{6}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}