using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!@20|@200)(@30)[^(@40)]{1,}(@40)(?!(@10|200)])";
string input = @"
את זה הוא תופס יפה
שלום לבא שבת@30שלום לבא שבת@40שלום לבא שבת
את זה אני רוצה שיתפוס
שלום שלום @30 מנוחה ושמחה אור ליהודים@40@
את זה אני לא רוצה שיתפוס
שלום שלום @30 מנוחה ושמחה אור ליהודים@40@10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}