const regex = /(?!@20|@200)(@30)[^(@40)]{1,}(@40)(?!(@10|200)])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!@20|@200)(@30)[^(@40)]{1,}(@40)(?!(@10|200)])', 'g')
const str = `
את זה הוא תופס יפה
שלום לבא שבת@30שלום לבא שבת@40שלום לבא שבת
את זה אני רוצה שיתפוס
שלום שלום @30 מנוחה ושמחה אור ליהודים@40@
את זה אני לא רוצה שיתפוס
שלום שלום @30 מנוחה ושמחה אור ליהודים@40@10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}