#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:[a-z](?:[a-z0-9-]*[a-z0-9])?(?:\.[a-z0-9-]*[a-z0-9])*)?\.$"
Local $sString = "." & @CRLF & _
"a." & @CRLF & _
"a-9." & @CRLF & _
"abc." & @CRLF & _
"abc.a-c.abc." & @CRLF & _
"" & @CRLF & _
"a.-." & @CRLF & _
" -." & @CRLF & _
"-a." & @CRLF & _
"a-." & @CRLF & _
"a" & @CRLF & _
"abc.-bc" & @CRLF & _
"ab-.abc" & @CRLF & _
"abc.a-@c" & @CRLF & _
".." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"a.b.c--d." & @CRLF & _
"." & @CRLF & _
"a.bb.cc." & @CRLF & _
"a.b.ccc-d-e-f." & @CRLF & _
"a-bB." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
".a." & @CRLF & _
"a--b" & @CRLF & _
"a..b." & @CRLF & _
".a" & @CRLF & _
"a.bb.cc" & @CRLF & _
"a.b.ccc-d-e-f" & @CRLF & _
"a-bB" & @CRLF & _
"a" & @CRLF & _
".."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")