$re = '/^(?:[a-z](?:[a-z0-9-]*[a-z0-9])?(?:\.[a-z0-9-]*[a-z0-9])*)?\.$/im';
$str = '.
a.
a-9.
abc.
abc.a-c.abc.
a.-.
-.
-a.
a-.
a
abc.-bc
ab-.abc
abc.a-@c
..
a.b.c--d.
.
a.bb.cc.
a.b.ccc-d-e-f.
a-bB.
.a.
a--b
a..b.
.a
a.bb.cc
a.b.ccc-d-e-f
a-bB
a
..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);