import Foundation
let pattern = #"^(?:[a-z](?:[a-z0-9-]*[a-z0-9])?(?:\.[a-z0-9-]*[a-z0-9])*)?\.$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
.
a.
a-9.
abc.
abc.a-c.abc.
a.-.
-.
-a.
a-.
a
abc.-bc
ab-.abc
abc.a-@c
..
a.b.c--d.
.
a.bb.cc.
a.b.ccc-d-e-f.
a-bB.
.a.
a--b
a..b.
.a
a.bb.cc
a.b.ccc-d-e-f
a-bB
a
..
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)