use strict;
my $str = '.
a.
a-9.
abc.
abc.a-c.abc.
a.-.
-.
-a.
a-.
a
abc.-bc
ab-.abc
abc.a-@c
..
a.b.c--d.
.
a.bb.cc.
a.b.ccc-d-e-f.
a-bB.
.a.
a--b
a..b.
.a
a.bb.cc
a.b.ccc-d-e-f
a-bB
a
..';
my $regex = qr/^(?:[a-z](?:[a-z0-9-]*[a-z0-9])?(?:\.[a-z0-9-]*[a-z0-9])*)?\.$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}