import re
regex = re.compile(r"^Content\/([A-Z][a-zA-z0-9\_]*\/)*(BP|T|M|MI)\_[A-Z].[a-zA-Z]+\.(uasset|umap)", flags=re.MULTILINE)
test_str = "Content/Ass/Ass/Bdd_01/BP_Asset.uasset"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")