using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\$|£|€|₹).?\b(\d\d?)(?!(,|\.)\d)\b|\b\d\d?\b.?(\$|£|€|₹))";
string input = @"20 $.
20 000 $
20,000 $
20.000$
100,000$
$20
$ 20.000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}