re = /((\$|£|€|₹).?\b(\d\d?)(?!(,|\.)\d)\b|\b\d\d?\b.?(\$|£|€|₹))/m
str = '20 $.
20 000 $
20,000 $
20.000$
100,000$
$20
$ 20.000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end