$re = '/((\$|£|€|₹).?\b(\d\d?)(?!(,|\.)\d)\b|\b\d\d?\b.?(\$|£|€|₹))/m';
$str = '20 $.
20 000 $
20,000 $
20.000$
100,000$
$20
$ 20.000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);