import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\$|£|€|₹).?\\b(\\d\\d?)(?!(,|\\.)\\d)\\b|\\b\\d\\d?\\b.?(\\$|£|€|₹))";
final String string = "20 $.\n"
+ "20 000 $\n"
+ "20,000 $\n"
+ "20.000$\n"
+ "100,000$\n"
+ "$20\n"
+ "$ 20.000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}