# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?'year'\d{4})-(?'month'\d{1,2})-(?'day'\d{1,2})(.*.mp4)/$year\($month-$day\).mp4/gm;t' <<< "2020-7-3; blah.mp4
2022-08-03_blah.mp4
2013-04-03-20-34-08; blah.mp4"