import Foundation
let pattern = #"(?'year'\d{4})-(?'month'\d{1,2})-(?'day'\d{1,2})(.*.mp4)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2020-7-3; blah.mp4
2022-08-03_blah.mp4
2013-04-03-20-34-08; blah.mp4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$year\($month-$day\).mp4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)