using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'year'\d{4})-(?'month'\d{1,2})-(?'day'\d{1,2})(.*.mp4)";
string substitution = @"$year\($month-$day\).mp4";
string input = @"2020-7-3; blah.mp4
2022-08-03_blah.mp4
2013-04-03-20-34-08; blah.mp4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}