use strict;
my $str = '37,080 lbs';
my $regex = qr/^[^0-9+-]+|([+-])[^0-9]+|([0-9])[^0-9.]+/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";