$re = '/\b(?:https?://)?(?:[\w-]+\.)*nytimes\.com/[\w/.\-#?&=]*\b/m';
$str = '|url=https://thelede.blogs.nytimes.com/2008/01/15/mona-lisas-identity-solved-for-good/?searchResultPosition=2&mtrref=www.nytimes.com&gwh=9DE4B32CC79812F2537467E9D52707E9&gwt=pay&assetType=REGIWALL}}
|url=https://www.nytimes.com/1987/01/09/opinion/l-couldn-t-mona-lisa-just-stay-a-mystery-361987.html |access-date=2022-07-10
[https://www.nytimes.com/2022/04/25/technology/musk-twitter-sale.html?searchResultPosition=19 Normal external link]
this one might be found someblog.nytimes.com/musk-twitter-sale#maybe?searchResultPosition=17 randomly in text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);