// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:https?://)?(?:[\w-]+\.)*nytimes\.com/[\w/.\-#?&=]*\b").unwrap();
let string = "|url=https://thelede.blogs.nytimes.com/2008/01/15/mona-lisas-identity-solved-for-good/?searchResultPosition=2&mtrref=www.nytimes.com&gwh=9DE4B32CC79812F2537467E9D52707E9&gwt=pay&assetType=REGIWALL}}
|url=https://www.nytimes.com/1987/01/09/opinion/l-couldn-t-mona-lisa-just-stay-a-mystery-361987.html |access-date=2022-07-10
[https://www.nytimes.com/2022/04/25/technology/musk-twitter-sale.html?searchResultPosition=19 Normal external link]
this one might be found someblog.nytimes.com/musk-twitter-sale#maybe?searchResultPosition=17 randomly in text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}