using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\:\s?([^;]+)(?<!default);";
string substitution = @": \1 !default;";
string input = @"$body-bg: theme-color(primary);";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}