use strict;
my $str = '$body-bg: theme-color(primary);';
my $regex = qr/\:\s?([^;]+)(?<!default);/p;
my $subst = ': \\1 !default;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";