$re = '/\:\s?([^;]+)(?<!default);/';
$str = '$body-bg: theme-color(primary);';
$subst = ": \1 !default;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;