re = /\:\s?([^;]+)(?<!default);/
str = '$body-bg: theme-color(primary);'
subst = ': \\1 !default;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result