using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z]+)[^a-z\r\n]*\.[a-z]{2,6}$";
string substitution = @"$1";
string input = @"http://www.mywebsiteameW1234.com
https://www.mywebsiteameW1234.com
http://mywebsiteameW1234.com
https://mywebsiteameW1234.com";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}