package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z]+)[^a-z\r\n]*\.[a-z]{2,6}$`)
var str = `http://www.mywebsiteameW1234.com
https://www.mywebsiteameW1234.com
http://mywebsiteameW1234.com
https://mywebsiteameW1234.com`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}