// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-z]+)[^a-z\r\n]*\.[a-z]{2,6}$").unwrap();
let string = "http://www.mywebsiteameW1234.com
https://www.mywebsiteameW1234.com
http://mywebsiteameW1234.com
https://mywebsiteameW1234.com";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}