import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z]+)[^a-z\\r\\n]*\\.[a-z]{2,6}$";
final String string = "http://www.mywebsiteameW1234.com\n"
+ "https://www.mywebsiteameW1234.com\n"
+ "http://mywebsiteameW1234.com\n"
+ "https://mywebsiteameW1234.com";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}