package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+(?:\.\w+)*)\s*(!=|=)\s*(\w+)`)
var str = `a.b.c = abc1 and def = def2 or g.hi != ghi3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}