$re = '/(\w+(?:\.\w+)*)\s*(!=|=)\s*(\w+)/m';
$str = 'a.b.c = abc1 and def = def2 or g.hi != ghi3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);