re = /(\w+(?:\.\w+)*)\s*(!=|=)\s*(\w+)/m
str = 'a.b.c = abc1 and def = def2 or g.hi != ghi3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end