// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+(?:\.\w+)*)\s*(!=|=)\s*(\w+)").unwrap();
let string = "a.b.c = abc1 and def = def2 or g.hi != ghi3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}