using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"www\.mywebsite\.com(*SKIP)(*FAIL)|(?:https?|ftp)://|(?:[a-z0-9]+\.)?[a-z0-9]+\.[a-z]{2,4}|\?[a-z0-9]+[&=#a-z]+";
string input = @"$url = 'This is url for example to remove www.somewbsite.com but i want to skip removeing this url www.mywebsite.com';
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}