re = /www\.mywebsite\.com(*SKIP)(*FAIL)|(?:https?|ftp):\/\/|(?:[a-z0-9]+\.)?[a-z0-9]+\.[a-z]{2,4}|\?[a-z0-9]+[&=#a-z]+/i
str = '$url = \'This is url for example to remove www.somewbsite.com but i want to skip removeing this url www.mywebsite.com\';
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end