const regex = new RegExp('www\\.mywebsite\\.com(*SKIP)(*FAIL)|(?:https?|ftp)://|(?:[a-z0-9]+\\.)?[a-z0-9]+\\.[a-z]{2,4}|\\?[a-z0-9]+[&=#a-z]+', 'gi')
const str = `\$url = 'This is url for example to remove www.somewbsite.com but i want to skip removeing this url www.mywebsite.com';
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}