import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "www\\.mywebsite\\.com(*SKIP)(*FAIL)|(?:https?|ftp)://|(?:[a-z0-9]+\\.)?[a-z0-9]+\\.[a-z]{2,4}|\\?[a-z0-9]+[&=#a-z]+";
final String string = "$url = 'This is url for example to remove www.somewbsite.com but i want to skip removeing this url www.mywebsite.com'; \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}