using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\/(?:[^\/]|(?<=\\)\/)+){2}";
string substitution = @"$0\n";
string input = @"/10/102-\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20
/10/102-\/ABC083.013\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}