import Foundation
let pattern = #"(?:\/(?:[^\/]|(?<=\\)\/)+){2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/10/102-\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20
/10/102-\/ABC083.013\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)