use strict;
my $str = '/10/102-\\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20
/10/102-\\/ABC083.013\\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20';
my $regex = qr/(?:\/(?:[^\/]|(?<=\\)\/)+){2}/mp;
my $subst = '$0\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";