using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+/\d+/\d+\s(?:-\s)?\d+/\d+/\d+$";
string input = @"11/13/2019 - 11/13/2019
11/14/2019 11/14/2019";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}