$re = '/^\d+/\d+/\d+\s(?:-\s)?\d+/\d+/\d+$/m';
$str = '11/13/2019 - 11/13/2019
11/14/2019 11/14/2019';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);