package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+/\d+/\d+\s(?:-\s)?\d+/\d+/\d+$`)
var str = `11/13/2019 - 11/13/2019
11/14/2019 11/14/2019`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}