re = /^\d+\/\d+\/\d+\s(?:-\s)?\d+\/\d+\/\d+$/m
str = '11/13/2019 - 11/13/2019
11/14/2019 11/14/2019'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end