import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([aeiou])\\1";
final String string = "De Haan\n"
+ "Greenberg\n"
+ "Khoo\n"
+ "Gee\n"
+ "Greene\n"
+ "Lee\n"
+ "Bloom\n"
+ "Feeney\n"
+ "Biegeleisen";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}