re = /([aeiou])\1/i
str = 'De Haan
Greenberg
Khoo
Gee
Greene
Lee
Bloom
Feeney
Biegeleisen'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end