$re = '/([aeiou])\1/i';
$str = 'De Haan
Greenberg
Khoo
Gee
Greene
Lee
Bloom
Feeney
Biegeleisen';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);