#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$\d{1,3}(?:,\d{3})*(?:\s+(?:thousand|[mb]illion|[MB]illion)|[M])?"
Local $sString = "The threat actors attacked its systems and encrypted the files and are apparently demanding $4.5 million for a decryptor and to prevent the release of stolen data." & @CRLF & _
"" & @CRLF & _
"The threat actors attacked its systems and encrypted the files and are apparently demanding $4.5 million for a decryptor and to prevent the release of stolen data." & @CRLF & _
"" & @CRLF & _
"$5 million" & @CRLF & _
"" & @CRLF & _
"$5.3M " & @CRLF & _
"" & @CRLF & _
"$5.6 million " & @CRLF & _
"" & @CRLF & _
"$333,333" & @CRLF & _
"" & @CRLF & _
"$2 million" & @CRLF & _
"" & @CRLF & _
"$5.3M"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")