$re = '/\$\d{1,3}(?:,\d{3})*(?:\s+(?:thousand|[mb]illion|[MB]illion)|[M])?/m';
$str = 'The threat actors attacked its systems and encrypted the files and are apparently demanding $4.5 million for a decryptor and to prevent the release of stolen data.
The threat actors attacked its systems and encrypted the files and are apparently demanding $4.5 million for a decryptor and to prevent the release of stolen data.
$5 million
$5.3M
$5.6 million
$333,333
$2 million
$5.3M';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);