use strict;
my $str = 'The threat actors attacked its systems and encrypted the files and are apparently demanding $4.5 million for a decryptor and to prevent the release of stolen data.
The threat actors attacked its systems and encrypted the files and are apparently demanding $4.5 million for a decryptor and to prevent the release of stolen data.
$5 million
$5.3M
$5.6 million
$333,333
$2 million
$5.3M';
my $regex = qr/\$\d{1,3}(?:,\d{3})*(?:\s+(?:thousand|[mb]illion|[MB]illion)|[M])?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}